SailNet Community - View Single Post - solar charging problem - troubleshooting help please!
View Single Post
  #13  
Old 03-12-2013
Cruisingdad's Avatar
Cruisingdad Cruisingdad is offline
Best Looking MALE Mod
 
Join Date: Jul 2006
Location: Washington State
Posts: 9,904
Thanks: 3
Thanked 108 Times in 53 Posts
Rep Power: 10
Cruisingdad is a jewel in the rough Cruisingdad is a jewel in the rough Cruisingdad is a jewel in the rough
Re: solar charging problem - troubleshooting help please!

Quote:
Originally Posted by copacabana View Post
I have been noticing that my two 65w solar panels have been increasingly unable to charge my batteries. The batteries seem to charge fine with the alternator and hold a charge well (they are less than 2 years old). I am thinking that perhaps there is a corroded connection somewhere between the panels and the batteries. Before I start looking at every possible culprit, perhaps someone with more experience might know where to start looking first. I'm not exactly a McGyver with things electrical ...

Thanks in advance!
Well... how did it turn out?
__________________
Sailnet Moderator



1987 Tayana Vancouver 42, Credendo Vides, (Mom and Pops boat, F/T Mobile Live Aboards in Puget Sound)

My Website:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow My Blog at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow me on Facebook:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook