SailNet Community - View Single Post - Beta20 alternator vs battery
View Single Post
post #3 of Old 05-06-2013 Thread Starter
deltaten
Senior Member
 
deltaten's Avatar
 
Join Date: Oct 2012
Location: Lancaster Co. PA/ North East, MD
Posts: 778
Thanks: 7
Thanked 19 Times in 19 Posts
Rep Power: 3
 
Send a message via Yahoo to deltaten
Re: Beta20 alternator vs battery

Well......I didn't go quite that far, Tommays; but I came close!

Ended up *still* not having enuff juice. Started by completely discon'ing the bat and working from there with a hot-charged/toppped off battery. Straight hooked it to the engine and checked volts. Oooops! only 10.75. Discon'd and came back to near 12.48 (FROM ORIG 12.54).
I pulled the key/instrument panel and started checking wires..........

Seems some bonehead swapped out the original Beta?Kubota ign sw for a generic. Had the glow plug line set up on an "accessory" terminal that was always hot when keyed on. No wonder i couldn;t make juice!?! Damm'd plugs draw one helluva lotta juice! I wired a switch in the plug line and , wonder of wonders!!!!!!!!!!!!! it works.

Motor started up, ran better and for it's favor, got the oil changed AFter all was settled, I re-hooked the DC pamnel and started tracing/checking switched lines. Most all the lites, tec work; just bad bulbs!

Now, on to other projects!

Thanx for the tip,
Paul

S/V Chrysalis
'80 Watkins 27
North East, MD
deltaten is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome