SailNet Community - View Single Post - Apparently I'm not meant to have a boat...
View Single Post
  #262  
Old 06-19-2013
jimgo's Avatar
jimgo jimgo is offline
Asleep at the wheel
 
Join Date: Sep 2011
Location: Pennsylvania
Posts: 2,745
Thanks: 69
Thanked 102 Times in 100 Posts
Rep Power: 3
jimgo is on a distinguished road
Re: Apparently I'm not meant to have a boat...

Rick, I think you made a lot of valid points, and I've been re-hashing them many times over the past many weeks. It's ironic, though, I've had engine problems on both of my boats - the Honda on the C25 had problems in the water pump (the molded-in base in the lower unit, not the part that could be inexpensively replaced), and we wound up replacing that engine with a new one. This boat has problems in the "powertrain", and we're rebuilding parts of it.

For me, the take-away is that you never REALLY know what's wrong with the boat until you get it home and actually start using it (or, in my case, try to get it home). There may well be significant hidden costs in any boat.

My wife made the point that, for what we'll be investing in this boat, we could have bought a different boat in better condition. But this particular problem may be lurking in ANY boat, and unless you want to pay to have the engine disassembled, or if the PO can show you that it's been replaced recently, you'll never know that the problem exists.
__________________
- Jim
Home: Western Philly 'burbs
1980 Allmand 31
1975 Albacore 15


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook