SailNet Community - View Single Post - Apparently I'm not meant to have a boat...
View Single Post
post #280 of Old 06-24-2013 Thread Starter
jimgo
Asleep at the wheel
 
jimgo's Avatar
 
Join Date: Sep 2011
Location: Pennsylvania
Posts: 3,014
Thanks: 71
Thanked 117 Times in 115 Posts
Rep Power: 4
 
Re: Apparently I'm not meant to have a boat...

Thank you, all this talk about floating debris is making me feel better about not being in the water!



I spent some time with the boat again on Saturday. I took advantage of the fact that she was out of the water and put the new name on. Of course, that meant that I first had to wash the hull (Awlwash) then clean the area where the name is to go, then get both sides aligned properly, etc. Then some Awlcare over everything. That "simple" job turned out to take from about 9:45 until a little after 1:00 PM. Then I replaced the gaskets and screens in 4 of the 6 opening ports. That, too, took longer than I expected, which is why only 4 got done. Then I made patterns for the dodger. That was an experience.

The engine was still off the boat, and I didn't see any obvious signs of it having been worked on. I called late last week to get a status update, but they didn't return my call which is a little disappointing. Hopefully I'll hear something today, otherwise I'll call them tomorrow.

- Jim
Home: Western Philly 'burbs
1980 Allmand 31
1975 Albacore 15


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jimgo is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome