SailNet Community - View Single Post - Apparently I'm not meant to have a boat...
View Single Post
  #280  
Old 06-24-2013
jimgo's Avatar
jimgo jimgo is offline
Asleep at the wheel
 
Join Date: Sep 2011
Location: Pennsylvania
Posts: 2,916
Thanks: 71
Thanked 108 Times in 106 Posts
Rep Power: 3
jimgo is on a distinguished road
Re: Apparently I'm not meant to have a boat...

Thank you, all this talk about floating debris is making me feel better about not being in the water!



I spent some time with the boat again on Saturday. I took advantage of the fact that she was out of the water and put the new name on. Of course, that meant that I first had to wash the hull (Awlwash) then clean the area where the name is to go, then get both sides aligned properly, etc. Then some Awlcare over everything. That "simple" job turned out to take from about 9:45 until a little after 1:00 PM. Then I replaced the gaskets and screens in 4 of the 6 opening ports. That, too, took longer than I expected, which is why only 4 got done. Then I made patterns for the dodger. That was an experience.

The engine was still off the boat, and I didn't see any obvious signs of it having been worked on. I called late last week to get a status update, but they didn't return my call which is a little disappointing. Hopefully I'll hear something today, otherwise I'll call them tomorrow.
__________________
- Jim
Home: Western Philly 'burbs
1980 Allmand 31
1975 Albacore 15


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook