SailNet Community - View Single Post - Westerbeke/Universal Diesel Problems
View Single Post
  #19  
Old 07-29-2013
eherlihy's Avatar
eherlihy eherlihy is offline
Learning the HARD way...
 
Join Date: Jan 2007
Location: Boston Area
Posts: 3,460
Thanks: 107
Thanked 57 Times in 56 Posts
Rep Power: 8
eherlihy will become famous soon enough
Re: Westerbeke/Universal Diesel Problems

Quote:
Originally Posted by stowe18 View Post
Hello all..


I wound up replacing the oil sender and the oil pressure switch- and that did nothing. Had a mechanic come (i was out of ideas) and he was just about to rip apart the engine after about 2 hours of scrounging around.. I had one more idea before he did that. Look at the vacuum gauge. That was the problem. It was leaking air into the fuel supply. So I took it off and stuck a screwdriver into the hose and engine started. Works fine! I guess a lot of maintenance work was done in the process..

Thanks for all the suggestions!!
Thank YOU for the follow up!
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

USCG Licensed OUPV Captain, ASA 101/103/104/105 Certified Instructor - Also certified in Recreational Marine Electrical Systems


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Getting back onto the water after undergoing knee surgery.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook