SailNet Community - View Single Post - Raymarine ST 60 Questions
View Single Post
  #1  
Old 10-17-2013
BarryL's Avatar
BarryL BarryL is offline
Senior Member
 
Join Date: Aug 2003
Location: Long Island, NY
Posts: 1,615
Thanks: 3
Thanked 27 Times in 26 Posts
Rep Power: 12
BarryL is on a distinguished road
Raymarine ST 60 Questions

Hello,

I am going to have a bunch of questions on my new to be boat. This one involves electronics - specifically the ST 60 tridata and wind instrument. As I previously posted, the ST 60 wind half works - the wind speed is OK but the wind direction just spins.

I received the wiring test and performed it - all voltages were normal. This test was performed at the junction box where the wires exited the mast. I want to repeat the test at the instrument itself but I can't seem to remove the instrument. It's mounted on a bulkhead next to the companionway. I can see the two thumb screws from inside, but when I remove them the instrument does not budge. Do I need to pull harder or am I missing something?

Next question: I don't believe my instruments are networked. If I try to display apparent wind I get ---. Is networking the ST 60 Speed and Wind as simply as plugging in a Seatalk cable?

Last question: the boat has a Garmin 740S plotter - which is fairly new and supports NMEA2000. Can I buy a Seatalk to NMEA2000 cable and connect all four instruments (wind, speed through water, depth, and plotter)?

Thanks,
Barry
__________________
Barry Lenoble
Deep Blue C, 2002 C&C 110
Mt. Sinai, NY

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook