SailNet Community - View Single Post - Xantrex Echo Charger Rant
View Single Post
  #22  
Old 05-07-2014
mlibkind mlibkind is offline
Junior Member
 
Join Date: Aug 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mlibkind is on a distinguished road
Re: EchoCharge Bench Tests 02/24/11

Quote:
Originally Posted by btrayfors View Post
Maine,

Happened to have a spare EchoCharge on hand, so did my own bench tests this morning.

These are indicative, not definitive since I didn't have the "right" batteries or enough time available.

For the "house bank", I used two 6V gelled golf-carts in series. These are 14 years old and are in pretty fair shape. They were not fully charged.

For the "start battery", I used a small 18AH West Marine AGM. It's about 3 years old and in fair shape. Also, not fully charged to begin the test.

Voltmeter was a Fluke 189. Ammeter was a Mastech MS-2108 clamp-type.

At the start, the resting voltages were 12.736 for the gels and 12.672 for the little AGM.

Note that voltages thruout are a bit higher than they would be with flooded cells, since both gels and AGMs typically have higher voltages.

Here are a couple of pix of the setup, and the results.

EchoChargeTest_0014

EchoChargeTest_0016

Voltage delivered to the "start" battery was never more than 14.4, even when charging voltage was near 15.

The multiple readings at the same indicated time were because I varied the charging voltage to see what the EchoCharge would do. Then, between times, I left the charging voltage at 14.8.

Not sure what all this means, yet.

My EchoCharge had the Heart Interface name on it. Xantrex may or may not have fiddled with the circuitry over the years....don't know for sure.

FWIW,

Bill
I know it didn't matter for your test, but so that others know, you should not, according to Xantrex, use the Echo Charge with different type batteries as you did. At least that is what they say.
Reply With Quote Share with Facebook