SailNet Community - View Single Post - OH duh! (lost my water!)
View Single Post
  #7  
Old 09-16-2007
sailingdog's Avatar
sailingdog sailingdog is offline
Telstar 28
 
Join Date: Mar 2006
Location: New England
Posts: 43,291
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 13
sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice
I wouldn't put a check valve in the line, since a check valve increases the work the engine water pump has to do to get water into the engine—not generally a good idea.

Also curious, but why did you not close the raw water intake on the boat before hauling it???

As the others have said, it should self-prime, and if it isn't self priming, then you've probably got something else going on.
__________________
Sailingdog

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Telstar 28
New England

You know what the first rule of sailing is? ...Love. You can learn all the math in the 'verse, but you take
a boat to the sea you don't love, she'll shake you off just as sure as the turning of the worlds. Love keeps
her going when she oughta fall down, tells you she's hurting 'fore she keens. Makes her a home.

—Cpt. Mal Reynolds, Serenity (edited)

If you're new to the Sailnet Forums... please read this
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

Still—DON'T READ THAT POST AGAIN.
Reply With Quote Share with Facebook