SailNet Community - View Single Post - engine trouble
Thread: engine trouble
View Single Post
  #6  
Old 01-23-2008
JohnRPollard's Avatar
JohnRPollard JohnRPollard is offline
Moderator
 
Join Date: Mar 2007
Location: Chesapeake
Posts: 5,680
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 10
JohnRPollard is a jewel in the rough JohnRPollard is a jewel in the rough JohnRPollard is a jewel in the rough
Quote:
Originally Posted by marinoinPV View Post
hello everybody
since first time i had problem and thanks to people here had fixed i have been enjoying my stay in my Catalina and doing lot of sailing in the bay of Banderas,but now i have problem. Water stopped coming out of the exaust. I trace the water intake and i opened the oberdorfer pump and the impeller is fine but i a gasket is missing and some (a bit ) water is leaking ,could this be the problem or i have to go further and open the heat exchanger which frankly im not sure how it works. pls if someone can shed a bit of info or some diagrams of the engine i will be much obliged!
Respect
Marino
Marino,

By "oberdorfer pump" are you referring to the raw water pump (i.e. the one that pulls water from outside the boat and pushes it through the heat exchanger)?

If the gasket to your raw water pump is missing, and the pump is dripping, then I would suspect the pump is sucking air due to the bad seal from the missing/worn gasket. If any air is being sucked in at the pump, it will lose suction and not draw the raw water in. My advice would be to replace the gasket as a first step, to stop the leak and seal the pump so it won't pull any air in. Then move on to the other suggestions above. Good luck.
Reply With Quote Share with Facebook