SailNet Community - View Single Post - HELP! Salt Water Pump
View Single Post
  #1  
Old 03-24-2003
nauticalrich's Avatar
nauticalrich nauticalrich is offline
Senior Member
 
Join Date: Aug 2001
Posts: 196
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 14
nauticalrich is on a distinguished road
HELP! Salt Water Pump

You are probably going to say, "not again"
But I have another problem.
I followed directions in my Universal diesel manual and removed the sea water pump for winter storage. Now I can''t get it back together.
Here the scenerio: Universal 14 hp in my 1985 ODay sloop. Removed impeller for winter. Purchased a new one. Neither the new one nor the orginal one seem to fit. I get it on the shaft but the only thing I can''t get on is the impeller snap ring. The impeller is so flush with the end of shaft I have no exposed goove to snap it into. Its as if the impeller is to wide but it is the same as the older one.

There must be a secret.

When I removed the impeller originaly, the shaft came out just a fraction and then right back in. It seems to be sitting ok and you can''t turn it. So it must be in where it belongs. Other than that I cannot understand why I can''t get it to the groove.
It looks impossible, whats the secrete?

Its the Orberdorfer. One pecular thing is that the manual states that if you pulled the shaft out by mistake you must remove the pump with two cap screws which attached it to the engine. I have 4 (bolts?).
Nothing is ever clear.
Reply With Quote Share with Facebook