SailNet Community - View Single Post - PSS Shaft Seal Question
View Single Post
post #1 of Old 03-22-2008 Thread Starter
danielgoldberg
Senior Member
 
danielgoldberg's Avatar
 
Join Date: Feb 2008
Location: New York
Posts: 679
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 8
 
PSS Shaft Seal Question

I've had this product on several boats and never had a problem. Now, I'm experiencing something funky and can't find any info on it. The aft edge of the stainless ring is now a little rough, and after some run time there appear to be "shards" (not sure how else to describe them) sticking out all around the ring. They're not stainless, not sharp and essentially disintegrate when you wipe them off. All I can think of is that the carbon stator is starting to wear (which it's not supposed to do) and the shards and roughness are actually carbon on top of the stainless ring. We're not getting water in. Yet. I'm really focusing on this now because I just read Tania Aebi's account in CW of her problem with her shaft seal, and it sounds an awful lot like my situation (though I'm not getting water in the boat, yet).

Anyone have experience with this kind of thing? I've never heard of these seals wearing, and my understanding is that they shouldn't.

Dan Goldberg

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
danielgoldberg is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome