SailNet Community - View Single Post - Raymarine ST4000 Autopilot....

   Search Sailnet:

 forums  store  
 
View Single Post
Old 03-24-2008   #2
Stillraining
Handsome devil
 
Stillraining's Avatar
 
Join Date: Jan 2008
Location: LaConner,Washington
Posts: 3,477
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 10
Stillraining is a jewel in the rough Stillraining is a jewel in the rough Stillraining is a jewel in the rough
I just called them for you but they are closed ...I will call tomorrow and ask them for you..

Quote:
Originally Posted by clayjay View Post
I have a Raymarine ST4000 Autopilot that is starting to sound like a bag of rusty nails. I've stripped it down and the problem seems to be a general lack of lubrication between the two rotating surfaces. This unit is of the type that bolts onto the wheel. Peering through there seems to be a host of small wheels and cogs but as they look plastic I am wodering waht would be best to use.....Silicon, Mr Sheen ??

Does anyone have a manual with/or any recommendations ???

I would also like to ad in passing that here in Australia it is impossible to contact Raymarine with any queries as they do not list a phone number anywhere on their web site and prefer to direct any queries to the UK.....now that's what I call great service !
Stillraining is offline   Reply With Quote Share with Facebook
 

All times are GMT -4. The time now is 02:23 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.