SailNet Community - View Single Post - Excalibur 26
Thread: Excalibur 26
View Single Post
post #7 of Old 05-10-2008
poopdeckpappy
Senior Member
 
poopdeckpappy's Avatar
 
Join Date: Jul 2006
Location: San Diego
Posts: 6,189
Thanks: 35
Thanked 42 Times in 36 Posts
Rep Power: 12
     
Wow,big time memories

Those two holes you see in the eng well sidewall is where one side of the motor support was threw bolted,should be two on the opposite side

When we first got ours it too had a transom mount but was a pita to operate, so I built a new motor mount inside the well and dropped in a new 5hp merc., leaving the motor in while under sail was a difference of 1 knot speed loss ( 7.3knots with motor in well was the best we ever did) and not a big deal for us.

The other thing I did was, I added a hatch on either side of the eng well, port side aft was access to the portable fuel tank that sat on a platform, right behind the hatch was a std. deck fuel fill, and this is where I would run the fuel line from the tank up threw the deck fill then to the motor, when not in use, it was easy to store the line and screw the cap on, the other side accessed a cooler,for them occasional dead air zones


Damn that was a cool boat

1955 Blanchard 51 Custom ( I got a woody )

1974 Ranger 33


Lord, give me coffee to change the things I can change and Rum to accept the things I can't

Last edited by poopdeckpappy; 05-10-2008 at 02:32 AM.
poopdeckpappy is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome