SailNet Community - View Single Post - Outboard Mount and the transom of a Cal 20
View Single Post
  #1  
Old 06-06-2008
lostcoast lostcoast is offline
Junior Member
 
Join Date: May 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
lostcoast is on a distinguished road
Outboard Mount and the transom of a Cal 20

Hello All,

Im new to the forums and sailing, just having purchased my first sailboat - a 1968 Cal 20. Im pretty excited, the boat is in fairly good shape but there are defininetly areas that need attention. The outboard well has been closed up and the previous owner installed a outboard bracket on the transom. While I like the configuration of this setup, the mount + motor ( a pretty small & light Merc 5hp) torque petty hard on the glass of the transom, causing the glass to bend outward at the top of the mount and push in at the bottom of the mount. The PO backed the installation of the mount with a chunk of PT 2x8, which given the look of the transom, isnt sufficient in this application.

The question I have is there anyone out there that has installed an outboard mount on the transom and if so, how did you reinforce it? Im thinking of running two vertical peices of aluminum L metal on either side of the backing plate to stiffen that section of the transom up. Any advice out there?

Finally anyone have a good method to get mildewy black spots off of the nonskid area of the deck? I scrubbed and scrubbed with a brush but couldnt get them to come clean ~ I was thinking of a bleach or Hydrogen Peroxide solution in the sun but am not sure how this will affect the gelcoat/paint.

THANKS!

Matt
Reply With Quote Share with Facebook