SailNet Community - View Single Post - Help! Advice needed.
View Single Post
  #4  
Old 06-24-2008
swadiver's Avatar
swadiver swadiver is offline
Senior Member
 
Join Date: Jan 2007
Location: Alta Loma, Ca.
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 8
swadiver is on a distinguished road
Heat

Midlifesailor;

I had a similiar problem with my Universal M25 when I moved my new boat from Oceanside to Long Beach, Ca. This should have been a 9 hour trip and I was by myself. Forty-five minutes out of port I checked my temp and I was overheating. I found that if I powered down I could keep the temp in a acceptable range. Needless to say a 9 hour trip took 14 hours. Turns out that the heat exchanger was toast and the intake hose was fouled. After installing a new one I have not had any problems and that was over a year ago. I still pay careful attention to the temp, check the coolant level, the raw water strainer, hoses and replaced the raw water impeller at the beginning of this season. And the next time I buy a boat I will also pay for a mechanical survey not just a rig and marine survey. My bad. I guess my advice would be to fix it. Enjoy your boat. Soon something else will break or an upgrade and you will forget all about this incident.
__________________
Scott

Long Beach, Ca.
s/v Namaste - 86 Catalina 30 , Tall Rig


The optimist expects the wind. The pessimist complains about the wind. The realist adjusts the sails.

Last edited by swadiver; 06-24-2008 at 09:20 PM.
Reply With Quote Share with Facebook