SailNet Community - View Single Post - Drive Belt For Autohelm 4000
View Single Post
post #9 of Old 07-22-2008
Senior Member
beej67's Avatar
Join Date: Apr 2008
Posts: 257
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 8
Might not be as much of a hijack as you think, Dog.

Originally Posted by rwberman View Post
My Autohelm ST4000 drive unit seems to have failed. I can't get the belt tension adjusted well enough to hold the clutch in the engaged position. Anybody know someone who wants to sell a working unit without the electronics?

Berman, try replacing the belt first. The old Raytheon belts tended to stretch, a *lot*, and the Poly Tech belt listed above is shade smaller in diameter than the old Raytheon belts, so they have better holding tension. (I just bought a few)

Also, if the handle won't stay engaged, but your existing unit still works fine as long as the handle is held in place, then just tie a piece of shock cord around the drive and use that to hold the handle down. I know of quite a few people who've done that with their ST4000s, as did I for a couple years before I bought new belts as per above. Yeah, it's kinda ghetto, but what works, works.

If you haven't ever replaced a belt before, it's pretty easy. The front and back halves of the unit snap together, so you can snap them apart (gently) with a long screwdriver. You'll need to remove some screws on a housing to get at the belt, but it's a piece of cake.

beej67, Checkered Past, 1980 32' Pearson 323, Panama City FL

Last edited by beej67; 07-22-2008 at 11:08 AM.
beej67 is offline  
Quote Share with Facebook
For the best viewing experience please update your browser to Google Chrome