SailNet Community - View Single Post - Need some quick Zinc/corrosion help and suggestions
View Single Post
post #8 of Old 01-25-2009 Thread Starter
nk235
Senior Member
 
nk235's Avatar
 
Join Date: Apr 2007
Location: Long Island
Posts: 404
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
 
Fstbottoms - if you lived here I would take you up on that offer in a heartbeat. It is also 17 degrees F here today though so I would need to find a diver with a dry suit.

Ok so here is the update. I uploaded a picture of what the shaft looks so now that you can all see it firsthand, what do you think? Also I coudl see that the zinc on the shaft is very deteriorated and half missing so I know there is a problem some where.

I also found out that the through holes on the boat are not bonded, but they look to be in good shape. Just the shaft is what scares me. What I am doing for the time being is I turned off the shore power and disconnected the cord. I am going to polish the inside portion of the shaft with a stainless steel brush and bronze polish. I am then going to get one of those fish zinc things with a 15' long wire. I am going to wrap the end of the wire around the inside portion of the shaft which is shown in the picture and then run the wire out into the cockpit and over the side where the fish zinc will sit in the water. Do you think this will help?

Thanks again for everyones responses

[IMG]shaft[/IMG]

Morgan 323
nk235 is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome