SailNet Community - View Single Post - Manual Bilge Pump
View Single Post
  #2  
Old 04-17-2009
sailingdog's Avatar
sailingdog sailingdog is offline
Telstar 28
 
Join Date: Mar 2006
Location: New England
Posts: 43,291
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 13
sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice
Yes, the hoses on most manual bilge pumps are rather large, since they are usually diaphragm pumps, and can move a fair bit of water but are low speed high volume... rather than an impeller based pump that is high speed low volume, so need a bigger hose.

The pickup location sounds a bit odd...but the reason it could be stuck is it may have a strum box on the end of the hose, and that may be too big to pull back through..


Photo courtesy of Westmarine.com

A strum box is basically designed to help keep debris that could clog or damage the pump out of the hose.
__________________
Sailingdog

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Telstar 28
New England

You know what the first rule of sailing is? ...Love. You can learn all the math in the 'verse, but you take
a boat to the sea you don't love, she'll shake you off just as sure as the turning of the worlds. Love keeps
her going when she oughta fall down, tells you she's hurting 'fore she keens. Makes her a home.

—Cpt. Mal Reynolds, Serenity (edited)

If you're new to the Sailnet Forums... please read this
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

Still—DON'T READ THAT POST AGAIN.
Reply With Quote Share with Facebook