SailNet Community - View Single Post - Leaking water pump.
View Single Post
  #9  
Old 07-03-2009
Maine Sail's Avatar
Maine Sail Maine Sail is offline
Senior Member
 
Join Date: Jan 2003
Location: Maine Coast
Posts: 5,530
Thanks: 13
Thanked 147 Times in 113 Posts
Rep Power: 15
Maine Sail is just really nice Maine Sail is just really nice Maine Sail is just really nice Maine Sail is just really nice
Quote:
Originally Posted by L124C View Post
I got the parts from the local Yanmar dealer. Strange thing is, the parts diagram (see picture) calls for 2 bearings (#7) and 1 oil seal (#8). No water seal. The motor is a 2GM20(F). I questioned the lady at Yanmar about it and she showed me the diagram (which she had nicely copied for me) and correctly said "your looking at the same thing I am". This makes me wonder, what keeps the water in the pump, and if I don't have a water seal, whats leaking? I could pull it apart, but have a race coming up and don't want to unable to get a part. Ideas?
Your pump is belt driven not engine driven therefore you only need one seal. That seal is for raw salt water or lake water. On some engines the pump bolts directly to the engine block where it is splash lubed by oil and driven directly off the engine so you'd have two seals one for water and one for the oil side.. Yours is driven by a belt thus one seal...
__________________
______
-Maine Sail / CS-36T


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




© Images In Posts Property of Compass Marine Inc.


Reply With Quote Share with Facebook