SailNet Community - View Single Post - Old merc outboard stuck...
View Single Post
post #1 of Old 08-10-2009 Thread Starter
blueranger
Member
 
blueranger's Avatar
 
Join Date: Jun 2006
Location: Colorado
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 10
 
Old merc outboard stuck...

After 3 hours hanging over my transom I come humbly to this forum for help with my head-scratcher. I have an older (1980s) mercury OB 7.5hp. Has forward, neutral, and reverse. Runs like a top; starts right up and goes through the gears no problem.

Today I pushed the engine to the right to insert the fuel line and somehow the engine locked in that position. This is a totally manual outboard. There's no trim, no power up and down or side to side. But something is keeping it locked to the right (starboard) side. I looked for any kind of switch but nothing. It has a little level labeled "Troll" that I have no idea what it does but playing with that didn't solve anything.

It feels exactly like when you turn the steering wheel of your car too far in Park and it locks. Anyhow I couldn't figure out the problem, a search of the net didn't turn up anything and I couldn't find any answers in my SELOC Mercury Outboards repair manual. I'm desperate. Any help would be GREATLY appreciated.

Thanks,
Mike

Last edited by blueranger; 08-10-2009 at 09:54 PM. Reason: spellign error
blueranger is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome