SailNet Community - View Single Post - Raymarine E120 backlight lost totally, anyone similar problem?
View Single Post
  #2  
Old 11-17-2009
Cruisingdad's Avatar
Cruisingdad Cruisingdad is offline
Best Looking MALE Mod
 
Join Date: Jul 2006
Location: Washington State
Posts: 9,904
Thanks: 3
Thanked 107 Times in 53 Posts
Rep Power: 10
Cruisingdad is a jewel in the rough Cruisingdad is a jewel in the rough Cruisingdad is a jewel in the rough
Mine has a 'quirk'. It is fine if you change from night to day or day to night viewing. However, if you press the power button at night and adjust down the brightness, after a few minutes, the screen does exactly what yours does. I have to completely shut the unit off and turn it back on. I just learned to use the day/night feature versus turning the contrast down.

I would suggest booting it back up and turning the brightness all the way up via pressing the power button briefly and turning the know clockwise. Afterwards, assuming that does not work, with the brightness all the way up, shut down and turn back on. If it still does not work, you are probably screwed.

THey say that electronics typicall go out in the first 30 days if they are going to go out. Looks like you may have gotten one of those if what I suggested does not work.

Brian
__________________
Sailnet Moderator



1987 Tayana Vancouver 42, Credendo Vides, (Mom and Pops boat, F/T Mobile Live Aboards in Puget Sound)

My Website:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow My Blog at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow me on Facebook:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook