SailNet Community - View Single Post - plug blues
Thread: plug blues
View Single Post
  #4  
Old 03-10-2010
sailingdog's Avatar
sailingdog sailingdog is offline
Telstar 28
 
Join Date: Mar 2006
Location: New England
Posts: 43,291
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 13
sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice
Given the photo, I would highly recommend disassembling the entire engine and treating it.

Quote:
Originally Posted by acceri View Post
I have an atomic 4 in my pearson 10m , 1974


spark plug is rusted in cyl #1, engine runs but plug hasnt been changed for 3 years. Now that its my boat, I'd like to fix that.. I tried wd 40..afraid to break it off..

how do I know if I have a direct drive or v drive? where can I read up on these?

I'd like to try and change the impeller as well..I think I need more than wd 40..
Photobucket
__________________
Sailingdog

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Telstar 28
New England

You know what the first rule of sailing is? ...Love. You can learn all the math in the 'verse, but you take
a boat to the sea you don't love, she'll shake you off just as sure as the turning of the worlds. Love keeps
her going when she oughta fall down, tells you she's hurting 'fore she keens. Makes her a home.

—Cpt. Mal Reynolds, Serenity (edited)

If you're new to the Sailnet Forums... please read this
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

Still—DON'T READ THAT POST AGAIN.
Reply With Quote Share with Facebook