SailNet Community - View Single Post - xantrex freedom marine 1500 inverter/charger issues
View Single Post
  #2  
Old 04-09-2010
sailingdog's Avatar
sailingdog sailingdog is offline
Telstar 28
 
Join Date: Mar 2006
Location: New England
Posts: 43,290
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 13
sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice sailingdog is just really nice
If the batteries are dead, then the inverter/charger may not work properly. IIRC, it will have issues if connected to dead batteries. That is probably why the display isn't working. I'd point out that AGM and Wet Cell batteries are pretty close, so that you can probably hook up the new batteries fairly safely, and then change the settings once the new batteries are online.
__________________
Sailingdog

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Telstar 28
New England

You know what the first rule of sailing is? ...Love. You can learn all the math in the 'verse, but you take
a boat to the sea you don't love, she'll shake you off just as sure as the turning of the worlds. Love keeps
her going when she oughta fall down, tells you she's hurting 'fore she keens. Makes her a home.

—Cpt. Mal Reynolds, Serenity (edited)

If you're new to the Sailnet Forums... please read this
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

Still—DON'T READ THAT POST AGAIN.
Reply With Quote Share with Facebook