SailNet Community - View Single Post - help! Rough running engine
View Single Post
  #1  
Old 07-16-2010
adamavis adamavis is offline
Junior Member
 
Join Date: Sep 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
adamavis is on a distinguished road
help! Rough running engine

Hi,

I recently acquired an ericson 25 which came with an OMC Saildrive 15. The engine has had some work, including the iso seal.
The engine does not idle very well and it seems to miss and it will stall.

Last week I was entering the marina and I keep the throttle up to avoid a stall I lost all power and it bogged down. When I eventually got to my slip there was a gas smell. Upon inspection I saw gas leaking from the fuel line. It was rubber and very corroded and broke in my hand when I squeezed it.

I replaced the fuel line from the gas tank to the primer, the primer to the engine connector. There is still a small rubber hose from the engine connector to the fuel pump and then a metal line from the fuel pump to the carb.

After I replaced most of the fuel line it started and idled fine for a little while, as soon as it warmed up the miss came and the boat stalled.

Does this still sound like a vacuum problem? The gas tank is like 30 years old and I have yet to check the fuel filter. The fuel pump gasket may be suspect and I hate to even think about tearing apart the carb.

I'll probably get a cheap outboard gas tank to test and replace that remaining fuel line, then check the fuel filter. After that I'm not so sure where to start?

Any suggestions?
Reply With Quote Share with Facebook