SailNet Community - View Single Post - head troubles......
View Single Post
  #10  
Old 10-12-2010
Cruisingdad's Avatar
Cruisingdad Cruisingdad is offline
Best Looking MALE Mod
 
Join Date: Jul 2006
Location: Mobile Liveaboards
Posts: 9,894
Thanks: 3
Thanked 97 Times in 52 Posts
Rep Power: 10
Cruisingdad is a jewel in the rough Cruisingdad is a jewel in the rough Cruisingdad is a jewel in the rough
We actually put a bit of mineral oil in to keep the valves happy. I also have been using chloring tablets for years as it keep the smell out of the heads (rotten egg smell). However, as mentioned above, it will take its toll on the valves. We get anywhere from 6 months to 18 months before rebuilds (before we went to electric heads which do not seem to be very suceptible to those issues). But we still lube it up with mineral oil periodically. I generally pushes us well past the 6 months mark.

Everything is a trade off.

Brian
__________________
Sailnet Adminstrator & Moderator
Catalina 400 Technical Editor

2004 Catalina 400, Sea Mist IV (our boat, F/T Mobile Live Aboards in S FL and Keys primarily)
1987 Tayana Vancouver 42, Credendo Vides, (Mom and Pops boat, F/T Mobile Live Aboards in Puget Sound)

My Website:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow My Blog at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow me on Facebook:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook