SailNet Community - View Single Post - GROCO-HF Flush-Dry Problem
View Single Post
post #1 of Old 07-03-2006 Thread Starter
Junior Member
Join Date: Jul 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GROCO-HF Flush-Dry Problem

Iíve rebuilt my GROCO-HF and Iím having problems with the Flush-Dry lever position.

Using the diagram at , the flush lever (part 5) will not move to the flush-dry position. I did this rebuild because the gasket (part 10) wore out. The first time I replaced it, everything worked fine when pumping out the bowl and flushing water through the system. However, when I tried to operate the lever to the flush-dry position, I encountered a lot of resistance. I pushed it on over and managed to rip the gasket (part 10). When I bought another kit and replaced the gasket the lever still would not flip over to the flush-dry position. Given the cost of these kits, Iím not about to force it again!

Has anyone else run into this problem? As best I can tell from GROCOís documentation, everything is installed correctly. With the exception that I still canít see where the ďbridgeĒ (Part 8) goes, so it hasnít been installed. I didnít think that would be an issue given that the documentation says that it was added to later models. Could this be the source of my problem?

If there's a better place or forum to ask this question, please let me know.

Ronn is offline  
Quote Share with Facebook
For the best viewing experience please update your browser to Google Chrome