SailNet Community - View Single Post - 2 bank battery charger acting weird
View Single Post
post #3 of Old 02-03-2011
sailingdog
Telstar 28
 
sailingdog's Avatar
 
Join Date: Mar 2006
Location: New England
Posts: 43,290
Thanks: 0
Thanked 15 Times in 12 Posts
Rep Power: 14
         
What size are Bank1 and Bank2. If bank 2 is the starting bank, it may very well not need much of a charge, and drop quickly into float mode. If bank 1 is the large house bank and it is heavily used, the charger is far more likely to need to stay in bulk charge mode for a while, until the bank gets to 80-85% SOC and then will slowly drop voltage and amperage as the battery bank's ability to accept current drops.

What make/model is the charger? What size are the battery banks? BTW, as Stu points out, the charger's negative lead doesn't have to go to the batteries, but should be lead to the ground bus bar/post for the boat's 12 VDC system.

Sailingdog

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Telstar 28
New England

You know what the first rule of sailing is? ...Love. You can learn all the math in the 'verse, but you take
a boat to the sea you don't love, she'll shake you off just as sure as the turning of the worlds. Love keeps
her going when she oughta fall down, tells you she's hurting 'fore she keens. Makes her a home.

—Cpt. Mal Reynolds, Serenity (edited)

If you're new to the Sailnet Forums... please read this
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

Still—DON'T READ THAT POST AGAIN.
sailingdog is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome