SailNet Community - View Single Post - bilge pump blowing fuses
View Single Post
post #17 of Old 05-15-2011
CapitainMike
Senior Member
 
CapitainMike's Avatar
 
Join Date: Apr 2011
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5
 
Quote:
Originally Posted by GaryHLucas View Post
I am a bilge pump freak too. I don't even have one, manual or electric, but then neither do any of the other Etap owners! I do of course have a sponge and a bucket, as we all do.

Gary H. Lucas
You ETAP owners keep on about unsinkable that's really great but I think you have missed the point here. If you get holed below the water line you have to keep your batteries dry for obvious reasons and if there is no wind you are relying on your engine

I have 4 working bilge pumps, fore peak 1 manual. 1 saloon auto and manual plus float switch, 2 in the engine bilge auto with sensor its the deepest bilge in the boat and a spare pump and float switch.

If it starts to come in you got to get it out fast and a bucket is not a good idea.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Capitain Mike
Mediterranean Sea
Cobra 850
1978
8.68m
"Money won't buy you happiness but it will allow you to buy a yacht big enough to pull up along side it"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Please God be kind to me your sea is so wide and my boat is so small"
CapitainMike is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome