SailNet Community - View Single Post - Weird Charging Problem with Xantrex Charger
View Single Post
  #1  
Old 06-19-2011
Sailor-man Sailor-man is offline
Junior Member
 
Join Date: May 2003
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Sailor-man is on a distinguished road
Weird Charging Problem with Xantrex Charger

I'm having an electrical problem with my charging system. Just replaced the 7-year old CRISTEC charger on my Dufour sailboat with a Xantrex TrueCharge2 40A battery charger.

It works fine except when we run the refrigerator on shore power. When we turn on the fridge, after about 30 mins the charger shows a temperature warning. (According to the manual this indicates the charger itself is overheating). Suggested solution is to confirm fan is working. make sure the unit is in a suitable open area, etc.

The charger fan is working properly and the unit is mounted vertically in a good location. I have tried running the charger under load with all halogen lights and accessaries on except the refrigerator and it works fine. But if I turn on the fridge within 20-30 mins it shows the temp warning.

Thought initially that this might be a faulty charger, but the replacement one does exactly the same.

The refrigerator is a factory installed 12v Frigoboat "Frigomatic Madrid 35F" wired to the panel.

I've had some suggestions that a faulty connection on the AC side could be the problem and to check connections on the panel and refrigerator. I'll look again but everything looks ok there.

Any suggestions or other ideas would be most appreciated.
Reply With Quote Share with Facebook