SailNet Community - View Single Post - Yanmar 3YM30
Thread: Yanmar 3YM30
View Single Post
post #1 of Old 08-29-2011 Thread Starter
tomperanteau
Crotchety Old Member
 
tomperanteau's Avatar
 
Join Date: Jun 2009
Location: San Pedro Harbor, California
Posts: 903
Thanks: 2
Thanked 3 Times in 3 Posts
Rep Power: 7
 
Yanmar 3YM30

Recently while motoring we had a belt break on the engine. I didn't realize that it had broken for a minute or two, and the engine had overheated. I shut her down and replaced the best. She started right up and sounded great. I thought I had made it through a potential catastrophe.

Now it seems that, after filling her with water to test her, the engine almost immediately blows the top off the overflow tank. I can run it from cold, for about 10 seconds, and pressure builds up in the overflow and the top pops off. The overflow will slowly fill and I have to shut it down. I noticed that if I have the radiator cap off, water fill spray out of the opening when I crank the engine.

Anyone seen this before? The engine is practically new with around 180 hours on it. Could it be that the water in the engine is almost immediately boiling and building too much pressure?

Capt'n Tom Living Aboard 50/50

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

S/V Footprints

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Youtube

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1976 41' Morgan Out Island Sloop. Refitting and redoing her interior for an extended voyage.
tomperanteau is offline  
Quote Share with Facebook
 
 
For the best viewing experience please update your browser to Google Chrome