SailNet Community - View Single Post - Rule Mate 2000 Bilge Pump sticking on?
View Single Post
  #13  
Old 10-19-2011
L124C's Avatar
L124C L124C is offline
Senior Member
 
Join Date: Oct 2007
Posts: 1,388
Thanks: 48
Thanked 3 Times in 3 Posts
Rep Power: 8
L124C is on a distinguished road
Finally recieved a lame response from West Marine "Tech Support", basically suggesting I buy a West Marine pump instead.
My response to West Marine pretty much says it all!:
Your response was slow in coming, was non responsive and nothing short of disrespectful! You told me what I already knew, which was the very reason I sent West Marine the email. The Rule pump has "some issues". You could have talked to me like an adult and answered my questions, i.e., "The problem was a defective chip which has been replaced". However, the fact you were so vague, and suggested another product despite your claim that the "engineers" have assured you the problem has been addressed, tells me they either didn't tell you that, or you don't believe them. In either case, (as I asked previously) why is the product still on the West Marine shelves? At the very least, why don't your sales people know about the "issues". I wanted to get a automatic switch and bilge pump back in my boat ASAP. I don't have time to "consider options" about defective equipment sold by incompetent suppliers and sales people. By the time I received your response, I had returned the Rule pump, purchased (from another vendor) and installed a Johnson pump and switch which pumps 200 GPH more than the rule, and sells for $70 less.
How can you be of "further assistance"? By answering questions in a honest, straightforward and timely manner. You might also stop selling products when they are being returned on a regular basis, especially when the products are safety equipment!

Last edited by L124C; 10-19-2011 at 01:35 PM.
Reply With Quote Share with Facebook