leaking Lewmar opening port - SailNet Community
LinkBack Thread Tools
post #1 of 1 Old 03-07-2010 Thread Starter
Junior Member
Join Date: Mar 2010
Location: Tallahassee, Fl
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
leaking Lewmar opening port

seems to be near the latch on bottom side. Thinking it may be the rubber seal before i pull the port for a full rebed... thoughts?
sails7plj is offline  
Quote Quick Reply Share with Facebook

Quick Reply

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Race day gives fans a reason to keep coming back - Port Huron Times Herald NewsReader News Feeds 0 07-18-2006 09:15 AM
Our city was at its best - Port Huron Times Herald NewsReader News Feeds 0 07-15-2006 03:15 PM
Lewmar opening ports capttack Gear & Maintenance 2 08-10-2004 07:34 PM
Lewmar opening port leak ref_123 Gear & Maintenance 4 09-29-2003 10:36 AM
Lewmar port screens bista Gear & Maintenance 0 08-15-2001 07:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome