Im looking for working Standard DS-1 & SL-1 - SailNet Community
LinkBack Thread Tools
post #1 of 1 Old 09-16-2010 Thread Starter
Junior Member
Join Date: Sep 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Im looking for working Standard DS-1 & SL-1

Im restoring a Irwin 10-4 that sank the units are wasted the transducers are mounted in front with the wire ran through the side walls and it would be a pain to replace the harness and transducers. So if anyone out their has a standard horizon DS-1 and SL-1 or any other parts off a irwin 10-4 model (hatches etc.) contact me thanks
screwdriver8 is offline  
Quote Quick Reply Share with Facebook

Quick Reply

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
gps not working katthater Electronics 3 06-17-2009 07:15 AM
knotmeter lcd not working saurav16 Gear & Maintenance 8 09-01-2007 11:00 AM
Working while cruising n2boating Cruising & Liveaboard Forum 6 01-18-2007 04:10 PM
Tachometer not working?? bderosa Gear & Maintenance 4 08-02-2006 09:08 PM
Working Jib jsheler Chesapeake Bay 1 06-12-2006 07:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome