Columbia 43 v drive - SailNet Community
LinkBack Thread Tools
post #1 of 1 Old 07-27-2013 Thread Starter
Almost there!
Join Date: Sep 2012
Location: Tofino
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Columbia 43 v drive

My v drive wont engage either forward or reverse. The shaft spins when it is in neutral but as soon as I put my hand on it it stops turning. The shifter works and I can hear a clicking sound when shifting it into forward and reverse but no movement. Can anyone give me some advice?
IlovemyColumbia43 is offline  
Quote Quick Reply Share with Facebook

columbia-43 , v-drive

Quick Reply

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
jet drive dodgeboatguy Gear & Maintenance 14 07-26-2007 02:07 AM
OMC Sail Drive wilsonw Gear & Maintenance 1 06-06-2007 01:20 PM
First boat: Columbia 22 or Columbia 24? 7tiger7 Boat Review and Purchase Forum 5 05-31-2006 01:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome