2gm20f won't suck AntiFreeze - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel
 Not a Member? 


Like Tree1Likes
  • 1 Post By Vasco
Reply
 
LinkBack Thread Tools
  #1  
Old 11-24-2013
Junior Member
 
Join Date: Dec 2012
Location: ny
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
alechich is on a distinguished road
2gm20f won't suck AntiFreeze

Hi All, Had earlier thread that asked for advice on this and it helped, but, I am having trouble getting more then 1 gallon of AF through. When it starts, it starts to kick it out when the stainer output line is in a bucket or the container of AF! I decompressed the engine just to get the 1 gallon in, but now not taking any more. Is it the thermostat keeping it from circulating more? I didn't take it out. I got AF coming out of the drain by the dipstick so does that mean it at least got to the mixing elbow? Or could some lines already be frozen, there were one or two freezes but then melting temps here on the Hudson. I need to boost the batteries to try to start it again, hopefully want to still get more in by holding the strainer line up and funneling it in, and have it come out the beck. (I couldn't reasonably get the hoses off the elbow to get AF into the mixer? or muffler system, they were rock hard-frozen?)
Any advice appreciated.
Reply With Quote Quick reply to this message Share with Facebook
  #2  
Old 11-24-2013
CalebD's Avatar
Tartan 27' owner
 
Join Date: Jan 2008
Location: NYC
Posts: 4,617
Thanks: 4
Thanked 93 Times in 85 Posts
Rep Power: 7
CalebD will become famous soon enough
Re: 2gm20f won't suck AntiFreeze

T-stat should probably come out for this.

Can't you just get the engine running at idle and use the cooling water pump to suck in a gallon or two of pink stuff?

How far up the Hudson are you?
__________________
"The cure for anything is salt water~ sweat, tears, or the sea." ~Isak Denesen

Everybody has one:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message Share with Facebook
  #3  
Old 11-25-2013
dockbumdan's Avatar
dockbum
 
Join Date: Feb 2011
Location: Georgetown, MD
Posts: 42
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 0
dockbumdan is on a distinguished road
Re: 2gm20f won't suck AntiFreeze

that's strange! my yanmar 3gm SUCKS just fine.
__________________
DockbumDan
SV/Trinity
Sailing Associates
Slip W=11
Georgetown, Md.21930
Sassafras River, Md.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message Share with Facebook
  #4  
Old 11-25-2013
Vasco's Avatar
Warm Weather Sailor
 
Join Date: Sep 2006
Location: Toronto
Posts: 1,003
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 9
Vasco is on a distinguished road
Re: 2gm20f won't suck AntiFreeze

The f in the motor 2gm20f indicates fresh water cooling. No need to remove the thermostat. I suggest the impeller might have been damaged from the previous tries at winterizing. Check the impeller.
christian.hess likes this.
__________________
Rick I
Toronto in summer, Bahamas in winter.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Quick reply to this message Share with Facebook
  #5  
Old 11-26-2013
Senior Member
 
Join Date: Feb 2010
Location: Narragansett Bay
Posts: 9,490
Thanks: 10
Thanked 159 Times in 145 Posts
Rep Power: 6
Minnewaska will become famous soon enough Minnewaska will become famous soon enough
Re: 2gm20f won't suck AntiFreeze

If there are an air breaks, many impellers won't self prime. If the impeller itself isn't shot, you may have to fill the entire input with AF, then crank it over to get it flowing.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Jeanneau 54DS

In the harsh marine environment, something is always in need of repair. Margaritas fix everything.
Reply With Quote Quick reply to this message Share with Facebook
  #6  
Old 11-29-2013
JimsCAL's Avatar
Senior Member
 
Join Date: May 2007
Location: Glen Cove, NY
Posts: 2,497
Thanks: 2
Thanked 46 Times in 42 Posts
Rep Power: 8
JimsCAL is on a distinguished road
Re: 2gm20f won't suck AntiFreeze

Two possibilities come to mind. Problems with the raw water pump or a plug in the raw water cooling circuit. Based on your description, my vote is on the second. The Yanmar U-type mixing elbow is known for this problem. I would start there.
Reply With Quote Quick reply to this message Share with Facebook
  #7  
Old 11-29-2013
Senior Member
 
Join Date: Jul 2006
Posts: 964
Thanks: 1
Thanked 24 Times in 24 Posts
Rep Power: 9
aa3jy is on a distinguished road
Re: 2gm20f won't suck AntiFreeze

I'd also consider the Heat Exchanger if it hasnt seen maintainence in awhile..

http://www.yanmarmarine.co.uk/pdfs/s...al/EPB5494.pdf

..but I highly suspect the raw water impeller..
Reply With Quote Quick reply to this message Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bilge Pumps Won't Suck vtsailguy Gear & Maintenance 10 08-30-2012 03:33 PM
Automotive antifreeze vs. RV antifreeze for engine. dman535 Gear & Maintenance 18 09-30-2009 04:53 PM
Antifreeze harpguitar Gear & Maintenance 22 11-26-2008 02:42 PM
It Just Won't Suck- Antifreeze slocum2 Gear & Maintenance 22 10-27-2008 11:47 PM
antifreeze stm Gear & Maintenance 8 02-04-2004 03:53 PM


All times are GMT -4. The time now is 06:32 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.