Universal M18 Question - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel
 Not a Member? 

Diesel This is a forum dedicated to diesel engines and their applicable accessories.


Reply
 
LinkBack Thread Tools
  #1  
Old 06-03-2011
Junior Member
 
Join Date: Dec 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GrumpyPawPaw is on a distinguished road
Universal M18 Question

Wednesday was the first time we took our Ericson 30 out. We ran the M18 most of the time (approx. 5hr.) and everything was fine. This morning as I was checking the engine, I noticed the breather hose on top of the rocker cover is not connected to anything. There is very little oil at the tip, but no oil on the engine or anywhere. Is this hose suppose to be connected to anything and if so to what?
Reply With Quote Quick reply to this message Share with Facebook
  #2  
Old 06-03-2011
JimsCAL's Avatar
Senior Member
 
Join Date: May 2007
Location: Glen Cove, NY
Posts: 2,478
Thanks: 2
Thanked 45 Times in 41 Posts
Rep Power: 8
JimsCAL is on a distinguished road
On the 5411 (M15) on my previous boat, that tube was attached to the air intake by a wire clip. Vapors were thus drawn into the engine and burned.
Reply With Quote Quick reply to this message Share with Facebook
  #3  
Old 06-04-2011
Senior Member
 
Join Date: Oct 2000
Location: Portland, OR
Posts: 668
Thanks: 1
Thanked 6 Times in 6 Posts
Rep Power: 15
olson34 is on a distinguished road
Quote:
Originally Posted by GrumpyPawPaw View Post
Wednesday was the first time we took our Ericson 30 out. We ran the M18 most of the time (approx. 5hr.) and everything was fine. This morning as I was checking the engine, I noticed the breather hose on top of the rocker cover is not connected to anything. There is very little oil at the tip, but no oil on the engine or anywhere. Is this hose suppose to be connected to anything and if so to what?
The stock breather hose on my '88 Universal was simply led down the side of the block and ended by the port side motor mount. Since later iterations of the same engine have the hose led back over to the intake, I did the same.
No oily odor inside the boat since...

L

ps: lots of info - Universal engines and your boat model- avail. from other owners over at Ericsonyachts.org.

Last edited by olson34; 06-04-2011 at 11:05 AM.
Reply With Quote Quick reply to this message Share with Facebook
  #4  
Old 06-04-2011
Junior Member
 
Join Date: Dec 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GrumpyPawPaw is on a distinguished road
Thanks guys for your help.
Reply With Quote Quick reply to this message Share with Facebook
  #5  
Old 06-04-2011
Stu Jackson's Avatar
Senior Member
 
Join Date: Jul 2001
Posts: 802
Thanks: 0
Thanked 9 Times in 8 Posts
Rep Power: 14
Stu Jackson is on a distinguished road
Good idea to join the Ericson group message board, but you should also be familiar with Marine Diesel Engines and Engine Parts - Universal, Volvo, Westerbeke, Yanmar, MASE
__________________
Stu Jackson, C34, 1986, M25 engine, Rocna 10 (22#)
Reply With Quote Quick reply to this message Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dumb Universal M4-30 question pegasus1457 Diesel 5 12-20-2013 01:35 PM
universal M25 issues B I G degreeoff Diesel 16 02-07-2010 11:48 AM
Universal M25XP / Kubota D950 question kaptaindave Gear & Maintenance 8 12-02-2009 12:39 PM
Universal 25 question Joeclark57 Diesel 3 06-20-2009 06:02 PM
Universal M21, long story and fuel line question BarryL Gear & Maintenance 16 05-12-2008 03:37 PM


All times are GMT -4. The time now is 02:02 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.