velvet drive 10.18 overheats and prop stops - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel
 Not a Member? 
  #1  
Old 11-01-2011
Junior Member
 
Join Date: Oct 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
lady caribe is on a distinguished road
velvet drive 10.18 overheats and prop stops

my velvet drive looses after twenty minutes traction and overheats.after i replaced the needlebearing behind the oilpressurepump that was blown to pieces.the loose needles i found in the oilchannels.is it possible hat something blocks the oilflow to the heatexchanger.i took everything apart but cold not find any fault.as far as i know flows the oil from the upper hose on top through the exchanger and returns on the righthand downside.the exchanger is cold and the gearbox very hot.can it be that the oilpump doesnt have anymore enough pressure because of the scratches from the destroyed needles in the pumphousing or did i make a mistake when assembling.there is one stainless steelplate lying on the bottom of the housing on top of the magnet.this plate i did not find in the explosiondrawing. is there any repairmanual online for the velvetdrive 10.18
Reply With Quote Quick reply to this message Share with Facebook
Reply

Tags
gearbox , manual , troubleshooting , velvet drive

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Velvet Drive Model number?? CaptainDCD Irwin 0 09-12-2009 10:37 PM
Velvet Drive \Transmission? blackpro Gear & Maintenance 5 06-06-2009 10:54 PM
Borg-Warner 71C Velvet Drive Talisman66 Gear & Maintenance 1 06-02-2009 11:34 PM
Velvet Drive on Ford Lehman 4D254 cruisingmom Gear & Maintenance 0 03-27-2009 12:14 PM
Winterizing Yanmar & Velvet Drive CDC2 Gear & Maintenance 4 10-07-2008 09:14 AM


All times are GMT -4. The time now is 11:08 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.