Raw Water Pump Rust/Corrosion - SailNet Community
 
LinkBack Thread Tools
post #1 of 1 Old 05-04-2012 Thread Starter
Junior Member
 
Join Date: Feb 2010
Location: New York City
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Raw Water Pump Rust/Corrosion

Hey all-
My Sherwood Raw Water pump (Engine is Universal M4-30a) is showing signs of corrosion. Late last season, I noticed a small bit of water coming from the weep hole as well as some accompanying light rust and corrosion. I had the pump looked at and changed out seals etc...When checking out the engine last week at splash, I noticed some much heavier corrosion (typical greening, but also white, salty looking scale). I ran the engine under load at the dock, did not notice any drips, and temperature stayed within tolerance. But the rust/corrosion has me worried. How much rust/corrosion is too much? At what point is peace of mind worth just replacing the pump rather than rebuilding existing? Any thoughts appreciated.
Thanks,
pk
pk5352 is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brown Rust water in bilge althedieselguy Gear & Maintenance 1 06-05-2011 07:17 PM
Water Pump? brianontheroad Gear & Maintenance 2 02-10-2009 08:34 PM
water pump Ariel1989 Gear & Maintenance 5 05-26-2008 09:15 PM
Rust and Corrosion. wind_magic Gear & Maintenance 4 06-17-2007 10:13 PM
2GM Raw Water Pump KenD Gear & Maintenance 1 05-10-2007 06:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome