westerbeke 30b3 engine stall - SailNet Community
 
LinkBack Thread Tools
post #1 of 8 Old 04-28-2013 Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
westerbeke 30b3 engine stall

I have a westerbeke 30b3 . When at normal operating temp the engine starts to lag then dies. As soon as it dies though it can imidiatly be restarted. Then the cycle of time to stall again gets shorter. I have replaced the lift pump,installed new racor 500 fiter/water sepparator.new filter cartrige on the engine, all new fuel line(send and return).new pickup tube.emptied tank and cleaned. Inspected 20 gallons of fuel(looked good). Still same problem. The mystey however is, after new lift pump filters I isolated the tank and lines and ran from a jerry can using lift pump and filters in the system and it ran great. This is what prompted replacing lines and cleaning tank. Any help would be gread as myself,friends and our local westerbeke mechanic are stumped.
BONES JONES is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-28-2013
Member
 
ScottyG24's Avatar
 
Join Date: May 2012
Posts: 91
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 4
 
westerbeke 30b3 engine stall

Check the fuel vent on the tank
ScottyG24 is offline  
Quote Quick Reply Share with Facebook
post #3 of 8 Old 04-28-2013 Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Re: westerbeke 30b3 engine stall

Vent was not the issue but, thank you for your input. So....my next attempt to find a problem was to use a new jerry can with newly purchased diesel. Set it next to the tank to test if the lift pump was not able to move the fuel the 20 feet required. Now, the diesel in my tank has red dye in it from a stop at afuel dock 2years ago. Started the engine....ran fine till it aproachedc operating temp. Starrted to lag and then almost died. As this was happining I watched the bowl on the filter go from pink to clear yellow. As the last of the red left the filter(durring my almost stall) she came back up and go an extra 50 RPM and ran grat with no lag or stall. The moral of this is.....BAD FUEL.
BONES JONES is offline  
Quote Quick Reply Share with Facebook
post #4 of 8 Old 04-28-2013
Member
 
ScottyG24's Avatar
 
Join Date: May 2012
Posts: 91
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 4
 
westerbeke 30b3 engine stall

glad you got it diagnosed
ScottyG24 is offline  
Quote Quick Reply Share with Facebook
post #5 of 8 Old 04-28-2013
Junior Member
 
Join Date: Feb 2013
Location: Palm Beach Gardens, FL
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Re: westerbeke 30b3 engine stall

Interesting that it would only stall at operating temp. Usually depending on how bad the fuel is it either wont run or runs consistently poorly.
Racecase is offline  
Quote Quick Reply Share with Facebook
post #6 of 8 Old 04-28-2013 Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Re: westerbeke 30b3 engine stall

Racecase I k.ow it the weirdest thing but there it is
BONES JONES is offline  
Quote Quick Reply Share with Facebook
post #7 of 8 Old 04-29-2013
Tartan 27' owner
 
CalebD's Avatar
 
Join Date: Jan 2008
Location: NYC
Posts: 4,754
Thanks: 4
Thanked 107 Times in 99 Posts
Rep Power: 8
 
Re: westerbeke 30b3 engine stall

This pic is of the last gallon or so of gasoline extracted from my tank a few years ago. The fuel tank had not been drained in an unknown (long, like 10 years) period of time.

Granted, this is gas and not diesel.
As Tony the Tiger used to say: "What's in your tank?" (old Esso commercial)
Attached Thumbnails
Dirtyfuel.jpg  

"The cure for anything is salt water~ sweat, tears, or the sea." ~Isak Denesen

Everybody has one:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CalebD is offline  
Quote Quick Reply Share with Facebook
post #8 of 8 Old 04-29-2013 Thread Starter
Junior Member
 
Join Date: Apr 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Re: westerbeke 30b3 engine stall

No more B5 diesel for me.!!!!!!!!
BONES JONES is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
broken westerbeke engine mounts in 331 finney Gear & Maintenance 1 01-29-2013 01:45 PM
westerbeke w30 - engine part identification :) druzhinin Diesel 13 07-17-2012 10:10 PM
Engine stall Tweegs Gear & Maintenance 1 06-15-2011 03:16 PM
Westerbeke 21 Diesel Engine Question... Sailing2636 Gear & Maintenance 11 04-14-2009 04:51 PM
Westerbeke 30B3 ssegal Beneteau 2 10-25-2006 10:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome