ICOM excellent service - SailNet Community
 
LinkBack Thread Tools
post #1 of 3 Old 11-13-2013 Thread Starter
Fisher motorsailor
 
Join Date: Nov 2013
Location: Devon, England
Posts: 11
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 0
 
ICOM excellent service

Hi all

I have an ICOM 411 which stopped receiving although was happy to transmit. I saw posts around the forums that suggested it was most likely a failed filter. After some initial hassle getting through ICOM's web site forms I was asked to send it back to them here in the UK. They fixed it for nothing even though it was over 4 years old and obviously out of warranty. It was returned by courier within a week.

It's not often we get that sort of service, so well done ICOM - with whom I have no connection, by the way.

Andrew
Andrew Thompson is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-13-2013
Learning the HARD way...
 
eherlihy's Avatar
 
Join Date: Jan 2007
Location: Boston / Ft Myers Area
Posts: 3,996
Thanks: 157
Thanked 99 Times in 96 Posts
Rep Power: 9
 
Re: ICOM excellent service

Thanks for the post! Usually, people only post gripes.

I also had to send an out of warranty radio back to iCom. I have an M34 handheld unit, which the squelch seemed to stop working. It locked on every channel, thus defeating the scan function. I sent it back to iCom 2 years after the warranty expired, and they repaired it, claiming that there was an ECO.

My enthusiasm was tempered, however, when the unit started to display the same symptom 6 months later. I have since learned that if I fully charge the battery, and then transmit (radio check), that the unit will work as it should for at least 6 hours.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

USCG Licensed OUPV Captain, ASA 101/103/104/105/106/118 Certified Instructor - Also certified in Recreational Marine Electrical Systems
eherlihy is offline  
Quote Quick Reply Share with Facebook
post #3 of 3 Old 11-22-2013
Junior Member
 
Join Date: Feb 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Re: ICOM excellent service

Thanks for the encouragement. I have a 4 year old ICOM VHF that stopped transmitting.

I bought a cheepo replacement, which works fine but would rather that the ICOM logo back in my panel. I'll give the factory boys a try. My original efforts to make contact were in Mexico and the service there.....isn't. I'll let you know.
Boisesailor is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cal 20-- Excellent Starter Boat Jim H Cal 8 03-17-2013 11:21 AM
Excellent article on the AC L124C Racing 4 12-10-2011 02:40 PM
Anyone go out today? Excellent day. chrisncate General Discussion (sailing related) 2 09-29-2010 08:02 AM
Excellent sailing today NewsReader Mass Bay Sailors 0 09-09-2006 10:15 PM
Gale's Excellent Adventure SailNet Racing Articles 0 04-29-2001 08:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome