Raymarine ST4000+ repair - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Electronics
 Not a Member? 
  #1  
Old 07-31-2014
Junior Member
 
Join Date: Jul 2014
Location: Kentucky
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
workboots is on a distinguished road
Raymarine ST4000+ repair

I recently purchased a 1989 Hunter 27 with a Raymarine ST4000+ autopilot. After reading on a few forums I believe I have what is a common problem on these older units. I receive a low battery error and there is no output to the wheel motor when placing the unit in auto. The motor tests good and runs with 12v applied. I have read that the mosfet output supply is likely bad which makes sense from my electronics training. I have some soldering experience but am not a electronics person by trade.

Does anyone know of a reputable repair place/person?
or (long shot) does anyone know of someone with a working unit for sale?
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raymarine ST4000+ question ... MSN2Travelers Electronics 9 04-22-2010 11:12 PM
Raymarine ST4000 dougpad Gear & Maintenance 1 01-13-2010 11:12 AM
Raymarine ST4000 EdHouston Gear & Maintenance 0 08-06-2008 06:02 PM
Raymarine ST4000 Autopilot.... clayjay Gear & Maintenance 4 03-26-2008 02:58 AM
Raymarine ST4000 disengages by itself mmowry Gear & Maintenance 5 05-30-2007 07:49 PM


All times are GMT -4. The time now is 01:53 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.