autohelm 4000 corrosion question - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Electronics
 Not a Member? 
  #1  
Old 07-18-2012
Senior Member
 
Join Date: Nov 2002
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 12
ereiss is on a distinguished road
Question autohelm 4000 corrosion question

I think I have corrosion where the control unit (female) plugs into the male plug (which has the wiring to the wheel control as well as power). I get an initial beep and after a second of running a second beep and it is off. I'm assuming corrosion is leading to a power voltage drop.

I tried spraying BeoShield (sp?) on both parts with little impact. Any suggestions?

Oh, and the plastic screw that hold the two parts together was lost. Anyone have ideas for replacing it? Hate to give Raymarine $400 to fix this unit that runs perfectly otherwise.

Appreciate your help and suggestions.
__________________
Ed Reiss
Being There
Freedom F38 #154
out of Marion, MA
Reply With Quote Share with Facebook
  #2  
Old 07-18-2012
Senior Member
 
Join Date: Nov 2002
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 12
ereiss is on a distinguished road
Re: autohelm 4000 corrosion question

I wanted to share that I got some great support from CaptainDan99 on my AP problems. I have to give him a big Thank You and recommend him to anyone who is having problems with their autopilot or wants to purchase one.

Thank you, Dan
__________________
Ed Reiss
Being There
Freedom F38 #154
out of Marion, MA
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Autohelm 4000 sabre39RG SailNet FAQ 2 08-12-2011 11:56 PM
Autohelm 4000 help pebrown1 Electronics 1 09-09-2010 12:29 PM
Autohelm 4000 Gulfislander Gear & Maintenance 1 03-02-2009 06:58 PM
Autohelm 4000 k7pqs Gear & Maintenance 8 12-06-2008 10:31 AM
Autohelm 4000 R33 Gear & Maintenance 1 10-17-2001 10:24 AM


All times are GMT -4. The time now is 10:23 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012