SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Electronics (http://www.sailnet.com/forums/electronics/)
-   -   SR Mariner NAV-5A connector (http://www.sailnet.com/forums/electronics/99297-sr-mariner-nav-5a-connector.html)

wikerd 05-08-2013 12:04 PM

SR Mariner NAV-5A connector
 
I have an old SR Mariner NAV -5A/10 that has a corroded main wire harness connector. The connector is a 16-pin, female connector which all the sensors connect to the back of the main station computing unit. This is giving me incorrect readings, so I would like to replace it. The manufacturer said they do not have any, so does anyone know where I can get one. The connector is about 3" long and has set-screws to fasten the wires. I don't care if I have to solder the wires to it; I just need one that will slip down on the male pins which are on the PC board.

Dave
Top Cat

btrayfors 05-08-2013 06:50 PM

Re: SR Mariner NAV-5A connector
 
I'd try some DeOxit or other electronic contact cleaner first, if you haven't already done so. Spray it liberally on both connectors, let it dry, and work the connectors together a few times. You may be surprised!

Bill


All times are GMT -4. The time now is 12:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
(c) Marine.com LLC 2000-2012

 
For the best viewing experience please update your browser to Google Chrome