SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Gear & Maintenance (http://www.sailnet.com/forums/gear-maintenance/)
-   -   Westerbeke/Universal Diesel Problems (http://www.sailnet.com/forums/gear-maintenance/100989-westerbeke-universal-diesel-problems.html)

stowe18 07-01-2013 09:16 PM

Westerbeke/Universal Diesel Problems
 
I can’t get the marine diesel engine (3 cylinder Westerbeke/Universal 25 HP) on my sailboat to keep running. When cold, it starts ok and runs for about 1 – 2 minutes, then sputters and shuts off. It runs a little longer at low RPM than high RPM. After this short run and sputtering off, the engine won’t start again, it just sputters with the assistance of the starter. After the engine has sat a while, 20 minutes or so, the same thing happens again. The starter cranks the engine over just fine. I’ve thoroughly checked the fuel system and it seems to work ok. I have done the following:

Replaced the Raycor prefilter coming out of the fuel tank (the fuel looked clean but I replaced it anyway)
Replaced the fuel lift pump (the “old” one was only about 3 years old, looked like new and seemed to pump just fine)
When the glow plug button is pressed, one can hear the fuel lift pump working, just like on the original.
Replaced the fuel filter between the fuel lift pump and the injector pump
Bled the air (the system is supposed to be self bleeding, but I hot wired the lifter pump and manually bled anyway at the fuel filter between the lift pump and injector pump)
Pulled off lines between injector pump and injectors and observed fuel coming out of injector pump, no air bubbles.
Opened up the injectors and cleaned the jets – they were a little sooty, but not overly so.
I hot wired the lifter pump and heard fuel flowing through the overflow lines at the top of the injectors and dropping back into the fuel tank, as normal.
I have a vacuum gage between the Raycor filter and the fuel lift pump, and the gage shows 0 psi, no problem there.

What is the problem? The engine was very reliable till the onset of this problem from one outing to the next. I can’t think of ANYTHING we did between outings that should cause this. Is there a thermostat or something else somewhere that is shutting down the system? If so, what is it and where is it on this engine? The engine runs for such a short time that it is still cold to the touch. HELP!!!

messenger 07-01-2013 09:31 PM

Re: Westerbeke/Universal Diesel Problems
 
double check connections and condition of oil pressure switch...forward right of block...believe this is the part number..Westerbeke Oil Pressure Switch 37323 037323 | eBay

deniseO30 07-01-2013 09:45 PM

Re: Westerbeke/Universal Diesel Problems
 
The fuel pickup tube in your tank. check it. :) very overlooked and almost always sludge clogged, even in clean tanks.

Familycruisers 07-01-2013 09:55 PM

Re: Westerbeke/Universal Diesel Problems
 
From your description definitely fuel flow. Think Denise might have a winner.

stowe18 07-01-2013 10:01 PM

Re: Westerbeke/Universal Diesel Problems
 
How do you get it out to look at it?

stowe18 07-01-2013 10:03 PM

Re: Westerbeke/Universal Diesel Problems
 
I'll definitely do that .. Thanks for your help!

deniseO30 07-01-2013 10:05 PM

Re: Westerbeke/Universal Diesel Problems
 
If you tell us what boat/model you have maybe someone has the same boat and would know more. Most pick up tubes come out with the fitting that threads into the top of the tank. How do I know? BEEN THERE DONE THAT! LOL
http://www.wholesalemarine.com/media...3/033500_5.jpg

stowe18 07-01-2013 10:07 PM

Re: Westerbeke/Universal Diesel Problems
 
Why wouldn't the vacuum gauge (attached prior to the fuel lift pump) show a vacuum? The fuel tank was cleaned 3 years ago. It was NOT easy to get into!

stowe18 07-01-2013 10:09 PM

Re: Westerbeke/Universal Diesel Problems
 
Denise - will the screen come out through that hole?

stowe18 07-01-2013 10:11 PM

Re: Westerbeke/Universal Diesel Problems
 
By the way, its a 1986 35' O'Day, replaced with a new engine in 1998. The original engine was a 21hp bronze color Universal. The new engine is a silver painted Westerbeke 25 hp.


All times are GMT -4. The time now is 05:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012