Datamarine Corinthian II Wind Machine Problem - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > General Interest Forums > Gear & Maintenance
 Not a Member? 
  #1  
Old 09-30-2013
Member
 
Join Date: Jul 2006
Posts: 78
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 8
luv4sailin is on a distinguished road
Datamarine Corinthian II Wind Machine Problem

My Datamarine Corinthian II Wind Machine is having problems It reads 180* opposite of the real wind direction on all points of sail. It is not the wind paddle itself as it is not damaged. Anyone have any idea of a solution of the problem?
Reply With Quote Share with Facebook
  #2  
Old 09-30-2013
BarryL's Avatar
Senior Member
 
Join Date: Aug 2003
Location: Long Island, NY
Posts: 1,538
Thanks: 3
Thanked 17 Times in 16 Posts
Rep Power: 11
BarryL is on a distinguished road
Re: Datamarine Corinthian II Wind Machine Problem

Hey,

Mine will sometimes do that. To correct the problem, I turn off the wind gauge, sail on the wind angle the unit is showing, then turn it back on.

For some reason that works.

Barry
__________________
Barry Lenoble
Day To Remember, 1986 O'day 35 For Sale
Deep Blue C, 2002 C&C 110 For Sail
Mt. Sinai, NY

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook
  #3  
Old 10-01-2013
msmith10's Avatar
Junior member, rest old
 
Join Date: Feb 2009
Location: Columbus Ohio
Posts: 492
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 6
msmith10 is on a distinguished road
Re: Datamarine Corinthian II Wind Machine Problem

Mine does the same. Disconnecting the cable at the display momentarily will usually fix it, but I've gotten so I just let it be 180 off. If I can't tell that it's 180 off I've got a bigger problem.
__________________
Mark Smith
1977 C&C 30 Mk 1 hailing from Port Clinton, Ohio
Reply With Quote Share with Facebook
  #4  
Old 10-01-2013
JimsCAL's Avatar
Senior Member
 
Join Date: May 2007
Location: Glen Cove, NY
Posts: 2,165
Thanks: 0
Thanked 13 Times in 12 Posts
Rep Power: 7
JimsCAL is on a distinguished road
Re: Datamarine Corinthian II Wind Machine Problem

You can give these guys a call. They service Datamarine instruments.

DMI Marine, Inc.
Reply With Quote Share with Facebook
  #5  
Old 10-01-2013
msmith10's Avatar
Junior member, rest old
 
Join Date: Feb 2009
Location: Columbus Ohio
Posts: 492
Thanks: 3
Thanked 0 Times in 0 Posts
Rep Power: 6
msmith10 is on a distinguished road
Re: Datamarine Corinthian II Wind Machine Problem

Quote:
Originally Posted by JimsCAL View Post
You can give these guys a call. They service Datamarine instruments.

DMI Marine, Inc.
You can try it, but when I called them about this problem a few years ago they said they couldn't fix it. After spending $300 at DMI to repair a masthead unit that worked for one year I've decided that paying to fix anything on the Datamarine wind instruments isn't worth the cost. Just about any repair to the masthead unit is $300+ and there's no saying how long that will last.
I now use a handheld meter which is very accurate for speed, and a windex for direction. The windex is more responsive, and how often do you need to check windspeed?
__________________
Mark Smith
1977 C&C 30 Mk 1 hailing from Port Clinton, Ohio
Reply With Quote Share with Facebook
  #6  
Old 10-01-2013
DrB DrB is offline
Senior Member
 
Join Date: Mar 2007
Location: New England
Posts: 953
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 8
DrB will become famous soon enough
Re: Datamarine Corinthian II Wind Machine Problem

My DMI wind instrument hasn't worked properly in years. Direction vane seems to be Ok, but cups don't give accurate wind speed. A few days ago we were closehauled, going 6kts and the readout said 0. Cups were spinning like mad.

I guess one day I may replace it, but it's such a hassle. Need to unstep mast, remove unit, pull cable, install new cable, new wind unit, etc.

To OP, as msmith10 says, don't waste your money trying to fix. These things are like 20+ years old. Instead of spending $300 to fix, pay a little more and find a newer "used" Raymarine or Tic-Tac unit when you so desire.

DrB
__________________
If you liked my advice/response, give me some rep points. If you didn't......well what do you expect, it was free.
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behavior from DataMarine Wind Instrument BarryL Electronics 5 06-01-2012 03:03 PM
Datamarine Corinthian instrument opinions? thekeip Gear & Maintenance 5 10-19-2009 08:11 PM
Datamarine masthead wind unit question josrulz Gear & Maintenance 10 07-23-2009 11:07 PM
Datamarine LX360 Wind Station syeldell Gear & Maintenance 2 07-15-2007 10:12 PM
Datamarine wind direction arrow - replacement? 7tiger7 Gear & Maintenance 2 07-07-2007 09:19 AM


All times are GMT -4. The time now is 07:06 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012