NAVICO CORUS WP300CX BELT - SailNet Community
 
LinkBack Thread Tools
post #1 of 4 Old 01-21-2005 Thread Starter
Member
 
Join Date: Aug 2001
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 15
 
NAVICO CORUS WP300CX BELT

My autopilot keeps eating these belts and I''m looking for a cheap (but strong) substitute as the brand name ones are $US60 each. Any ideas?
Thanks.
Barbara
seagypsywoman@yahoo.ca
Seagypsywoman is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-21-2005
Senior Member
 
Join Date: Sep 2001
Posts: 180
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 14
 
NAVICO CORUS WP300CX BELT

I didn''t have any luck searching industrial supply houses even though the belt is manufactured by a well-known company with a catalog. Apparently, the belt is produced exclusively for Navico (now Simrad).
RichardElliott is offline  
Quote Quick Reply Share with Facebook
post #3 of 4 Old 03-05-2009
Junior Member
 
Join Date: Mar 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Barbara
There is one for sale on ebay for $16, brand new. It is a simrad wp30cx belt, which is the same. Simrad took over Navico. If you need help finding it, I will send you the link.
Safe winds
Ian
ianjory is offline  
Quote Quick Reply Share with Facebook
post #4 of 4 Old 03-05-2009
Best Looking MALE Mod
 
Cruisingdad's Avatar
 
Join Date: Jul 2006
Location: Washington State
Posts: 9,917
Thanks: 3
Thanked 124 Times in 57 Posts
Rep Power: 10
     
Quote:
Originally Posted by ianjory View Post
Barbara
There is one for sale on ebay for $16, brand new. It is a simrad wp30cx belt, which is the same. Simrad took over Navico. If you need help finding it, I will send you the link.
Safe winds
Ian

Ian... she probably already bought it since she posted in 2005!!

Brian

Sailnet Moderator



1987 Tayana Vancouver 42, Credendo Vides, (Mom and Pops boat, F/T Mobile Live Aboards in Puget Sound)

My Website:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow My Blog at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Follow me on Facebook:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cruisingdad is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for a Navico Depth display Spirit_of_America Gear & Maintenance 5 02-02-2008 06:06 PM
Navico Parts GaryCB Gear & Maintenance 1 02-23-2002 02:50 PM
Simrad vs. Navico Tiller Pilots jamesmm Gear & Maintenance 4 11-03-2001 03:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome