Sabre water pump - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance
 Not a Member? 
  #1  
Old 04-12-2001
Junior Member
 
Join Date: Apr 2001
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Ark Mike is on a distinguished road
Sabre water pump

I have a 28''Sabre with a Atomic 4 engin. I need to replace the water pump impeller which is located in the lower left back corner of the motor. Can not figure out a way to get to it without pulling the motor. Does anyone have any suggestions?
Reply With Quote Share with Facebook
  #2  
Old 04-12-2001
RichH's Avatar
Senior Member
 
Join Date: Jul 2000
Location: Pennsylvania
Posts: 2,752
Thanks: 9
Thanked 64 Times in 57 Posts
Rep Power: 15
RichH will become famous soon enough
Sabre water pump

Remove the grease cup body using a 7/16" wrench.
Remove the four screws on the cover plate and the cover plate.
Grab the base of the impeller, not the vanes, with a needle nose plier, etc. Wiggle the impeller until it moves out of the housing (many times it can be wiggled out without removing the grease cup). The impeller is held to the shaft with a small bronze circlip.
Thats it.
Hope this helps.
Reply With Quote Share with Facebook
  #3  
Old 04-17-2001
Junior Member
 
Join Date: Jul 2000
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
sailaftmid is on a distinguished road
Sabre water pump

try asking on the sabre-list e-mail group. You should get some good advice there. (just go to "join e-mail lists".
Reply With Quote Share with Facebook
  #4  
Old 06-07-2010
Junior Member
 
Join Date: Jun 2006
Location: Green Harbor Ma
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
phoxie is on a distinguished road
Sorry to bring up an old thread, but I have a Sabre 28 with an Atomic in it and I replaced the impeller this spring. Started the engine yesterday and at a low rpm, there was no water going thru the engine, causing the temp gauge to rise. If I gave it a little gas, the pump would sart to draw water and cool the engine down. Back off on the gas and the water stopped.

Thoughts, comments........

Thanks
Reply With Quote Share with Facebook
  #5  
Old 06-07-2010
tommays's Avatar
Senior Member
 
Join Date: Sep 2008
Posts: 4,228
Thanks: 1
Thanked 24 Times in 24 Posts
Rep Power: 6
tommays will become famous soon enough
On my A4 the orginal pump was so worn out i had to buy the Moyer Marine unit and replace it

You would need to inspect the pump and look at the shaft bore (my bore had worn huge) and the wear plate the impeller runs on to make suction

Also if the cover plate and rear of the pump wear the sides of the impeller rub is worn it will not work well
__________________
1970 Cal 29 Sea Fever

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1981 J24 Tangent 2930
Tommays
Northport NY


If a dirty bottom slows you down what do you think it does to your boat
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
MacGregor 26 vs. ? jiml2p Boat Review and Purchase Forum 199 10-01-2012 02:34 PM
Windward performance deseely General Discussion (sailing related) 21 04-01-2012 02:42 PM
water ballast musolmar Boat Review and Purchase Forum 8 09-26-2004 04:50 PM
Water Pump shaft on the move... ikent Gear & Maintenance 0 10-07-2003 04:20 PM
Water Ballast/Manufacturer RSJ Boat Review and Purchase Forum 6 03-07-2002 05:59 PM


All times are GMT -4. The time now is 05:08 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.