ST-60 trouble shooting - SailNet Community
 
LinkBack Thread Tools
post #1 of 2 Old 06-23-2016 Thread Starter
Master Mariner
 
capta's Avatar
 
Join Date: Jun 2011
Location: somewhere south of civilization
Posts: 3,928
Thanks: 86
Thanked 196 Times in 187 Posts
Rep Power: 6
 
ST-60 trouble shooting

Today our ST-60 went from being a functioning unit to being a bump on the pedestal.
One second it was working, the next not.
First thought was the transducer on the mast head had flown the coop, but it hadn't.
Both the wind direction and speed stopped working, but the direction needle (pointing straight up) twitches a tiny bit (not even a degree). The transducer is barely 2 years old, whereas the old one died after at least 5 years under my ownership and an unknown number of years with the PO.
Any ideas?

"Any idiot can make a boat go; it takes a sailor to stop one." Spike Africa aboard the schooner Wanderer in Sausalito, Ca. 1964.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

facebook.com/svskippingstone
Our Videos;

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
capta is online now  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-23-2016
Senior Member
 
overbored's Avatar
 
Join Date: Oct 2010
Location: Dana Point, Ca
Posts: 1,887
Thanks: 1
Thanked 124 Times in 123 Posts
Rep Power: 7
 
Re: ST-60 trouble shooting

Check the wiring in the mast the old mast head units had problem shorting out. aluminum block with connector on masthead
http://www.raymarine.co.uk/knowledge....cfm?view=4254

"FULL TILT II" 2011 BENETEAU FIRST 30
"GOLD RUSH" PRINDLE 16
overbored is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble shooting wind instrument. L124C Gear & Maintenance 15 07-30-2015 09:11 AM
Diesel Engine trouble-shooting JordanH Diesel 11 08-14-2012 08:20 AM
Auto Pilot Trouble-Shooting Needed Pub911 Gear & Maintenance 1 04-05-2010 06:58 AM
Trouble Shooting Moors Depth Sounder Finallybuyingaboat Gear & Maintenance 1 10-23-2007 11:07 PM
Trouble-shooting depth and speed guages billkidd Gear & Maintenance 0 08-20-2002 08:49 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome