Yanmar Oil Pressure Light/Alarm Out? Please help! - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance
 Not a Member? 
  #1  
Old 05-19-2008
gwp gwp is offline
Member
 
Join Date: Apr 2003
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
gwp is on a distinguished road
Yanmar Oil Pressure Light/Alarm Out? Please help!

1986 2GM20F
Can someone give me some ideas as to why, all of a sudden, when I turn the key to the "on" position, the oil pressure alarm doesn't sound nor the light come on? I'm pretty sure the sending unit is designed as normally closed, and it is grounded properly. When I throw the test switch, the alarm sounds and the "charge" light comes on. Trying to help a friend. Any help very much appreciated!
Reply With Quote Share with Facebook
  #2  
Old 05-19-2008
Senior Member
 
Join Date: Oct 2006
Location: Virginia
Posts: 722
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 8
badsanta is on a distinguished road
if it worked before and now not. I would check the fuses and ground. There may be some inline fuses buried in the wiring harness next to the engine
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yanmar oil pressure brak Gear & Maintenance 4 05-04-2008 09:40 PM
Oil Pressure Mystery Solved bsfree Gear & Maintenance 5 12-21-2007 07:23 PM
W60 - No oil pressure after oil change??? pma_foyl Gear & Maintenance 9 12-01-2004 09:45 AM
Changing Engine Oil Tom Wood Gear and Maintenance Articles 0 10-02-2002 08:00 PM
Oil Pressure Problems Tom Wood Gear and Maintenance Articles 0 05-16-2002 08:00 PM


All times are GMT -4. The time now is 10:24 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.