Xantrex won't equalize - SailNet Community
 
LinkBack Thread Tools
post #1 of 5 Old 04-17-2009 Thread Starter
Senior Member
 
Join Date: Aug 2006
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
 
Xantrex won't equalize

Hi All,
I have just hauled in Grenada and am trying to equalize my batt's before I leave the boat for the summer.
The problem is that when plugged in to shorepower and the equalising function started, the most volts shown is 14.05 and a charge current of 6.4 amps. When any electrical items are used the volts go down accordingly . Maybe thats normal . i don't know. The last time I tried to equalize I am not sure it worked , but did not have time to sort out the problem That was 4 months ago , the last time we were at a marina.

I have 6 6v T105 batts for a total of 675 amp in the house bank. Charged by a heart 20 inverter / charger. Monitored by a link 2000r.

Any ideas ??

Thanks in advance, Kevin.
kmclarke is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-17-2009
the pointy end is the bow
 
erps's Avatar
 
Join Date: Aug 2006
Location: La Conner, Washington
Posts: 6,260
Thanks: 2
Thanked 27 Times in 26 Posts
Rep Power: 10
   
I wonder if the setup software got changed? I think you're supposed to enter in the type of batteries you have and the size of the bank. The 'puter has to know what you have in order to charge it correctly. I think you're also not supposed to start the equalization process until it's already been fully charged. Do you still have your documentation?

Ray
S.V. Nikko
1983 Fraser 41
La Conner, WA


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Boating for over 25 years, some of them successfully.
erps is offline  
Quote Quick Reply Share with Facebook
post #3 of 5 Old 04-17-2009 Thread Starter
Senior Member
 
Join Date: Aug 2006
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
 
I waited until the batts were fully charged then started the equalize. The capacity is set correctly and the power share is at 30. Charged V is set at 13.2 as per the manual, and the amb temp is set for 90*F .

I am checking to see how I could set the link for an agm vs wet cell to see if that might be the culprit, but havn't found the info yet. I do have what appear to be the correct manuals , but they seem a bit vague where it counts.

Thanks for your reply, Kevin.
kmclarke is offline  
Quote Quick Reply Share with Facebook
post #4 of 5 Old 04-17-2009
Senior Member
 
Omatako's Avatar
 
Join Date: Sep 2003
Location: Auckland New Zealand
Posts: 2,536
Thanks: 1
Thanked 32 Times in 29 Posts
Rep Power: 12
 
Quote:
Originally Posted by kmclarke View Post
I waited until the batts were fully charged then started the equalize.
Kevin, check the documentation. I have strong recollection on my Xantrex mains charger instructions that before equalising, the battery water should be full and the batteries should be run right down before initiating the equalisation charge.

I suspect that your fully charged batteries are the problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

__________________

"Two possibilities exist: Either we are alone in the Universe or we are not. Both are equally terrifying."

Arthur C. Clarke
Omatako is offline  
Quote Quick Reply Share with Facebook
post #5 of 5 Old 04-18-2009 Thread Starter
Senior Member
 
Join Date: Aug 2006
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
 
I checked the manual and it does say to start the equalize charge after the batts have been fully charged.
Kevin
kmclarke is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
LINK 2000 R Help needed with regulator Volkhard Gear & Maintenance 27 03-17-2009 07:20 PM
Xantrex EchoCharge jason3317 Gear & Maintenance 13 12-03-2008 02:17 PM
Blue Sky v Xantrex lbdavis Gear & Maintenance 3 11-21-2008 08:23 PM
Xantrex Truecharge 40+ only charging at 20 amps? PilotAlso Gear & Maintenance 3 07-11-2008 12:52 PM
replacing AGM battery peterbelsky Gear & Maintenance 17 11-05-2007 11:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome