Xantrex won't equalize - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance
 Not a Member? 
  #1  
Old 04-17-2009
Senior Member
 
Join Date: Aug 2006
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
kmclarke is on a distinguished road
Xantrex won't equalize

Hi All,
I have just hauled in Grenada and am trying to equalize my batt's before I leave the boat for the summer.
The problem is that when plugged in to shorepower and the equalising function started, the most volts shown is 14.05 and a charge current of 6.4 amps. When any electrical items are used the volts go down accordingly . Maybe thats normal . i don't know. The last time I tried to equalize I am not sure it worked , but did not have time to sort out the problem That was 4 months ago , the last time we were at a marina.

I have 6 6v T105 batts for a total of 675 amp in the house bank. Charged by a heart 20 inverter / charger. Monitored by a link 2000r.

Any ideas ??

Thanks in advance, Kevin.
Reply With Quote Share with Facebook
  #2  
Old 04-17-2009
erps's Avatar
the pointy end is the bow
 
Join Date: Aug 2006
Location: La Conner, Washington
Posts: 6,166
Thanks: 2
Thanked 26 Times in 26 Posts
Rep Power: 10
erps will become famous soon enough erps will become famous soon enough
I wonder if the setup software got changed? I think you're supposed to enter in the type of batteries you have and the size of the bank. The 'puter has to know what you have in order to charge it correctly. I think you're also not supposed to start the equalization process until it's already been fully charged. Do you still have your documentation?
__________________
Ray
S.V. Nikko
1983 Fraser 41
La Conner, WA


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Boating for over 25 years, some of them successfully.
Reply With Quote Share with Facebook
  #3  
Old 04-17-2009
Senior Member
 
Join Date: Aug 2006
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
kmclarke is on a distinguished road
I waited until the batts were fully charged then started the equalize. The capacity is set correctly and the power share is at 30. Charged V is set at 13.2 as per the manual, and the amb temp is set for 90*F .

I am checking to see how I could set the link for an agm vs wet cell to see if that might be the culprit, but havn't found the info yet. I do have what appear to be the correct manuals , but they seem a bit vague where it counts.

Thanks for your reply, Kevin.
Reply With Quote Share with Facebook
  #4  
Old 04-17-2009
Omatako's Avatar
Senior Member
 
Join Date: Sep 2003
Location: Auckland New Zealand
Posts: 2,413
Thanks: 0
Thanked 28 Times in 25 Posts
Rep Power: 12
Omatako will become famous soon enough
Quote:
Originally Posted by kmclarke View Post
I waited until the batts were fully charged then started the equalize.
Kevin, check the documentation. I have strong recollection on my Xantrex mains charger instructions that before equalising, the battery water should be full and the batteries should be run right down before initiating the equalisation charge.

I suspect that your fully charged batteries are the problem.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

__________________

"Two possibilities exist: Either we are alone in the Universe or we are not. Both are equally terrifying."

Arthur C. Clarke
Reply With Quote Share with Facebook
  #5  
Old 04-18-2009
Senior Member
 
Join Date: Aug 2006
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
kmclarke is on a distinguished road
I checked the manual and it does say to start the equalize charge after the batts have been fully charged.
Kevin
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LINK 2000 R Help needed with regulator Volkhard Gear & Maintenance 27 03-17-2009 07:20 PM
Xantrex EchoCharge jason3317 Gear & Maintenance 13 12-03-2008 02:17 PM
Blue Sky v Xantrex lbdavis Gear & Maintenance 3 11-21-2008 08:23 PM
Xantrex Truecharge 40+ only charging at 20 amps? PilotAlso Gear & Maintenance 3 07-11-2008 12:52 PM
replacing AGM battery peterbelsky Gear & Maintenance 17 11-05-2007 11:23 PM


All times are GMT -4. The time now is 05:35 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.